amibroker

HomeDevLog

TWS 860.9 breaks compatiblity? Or… rather internal IB problem???

Following IB “tradition” new version 860.9 of TWS breaks compatiblity with existing 3rd party software.
It gives “invalid symbol” error in many cases.

The only TWS recommended version to use is 858.6 or earlier.

If you already upgraded to 860.9 you need to revert back to 858.6
http://www.interactivebrokers.com/download/tws40_install_prev.exe

General rule is NEVER upgrade TWS until we give OK that new version of TWS is OK,
as in the past there were many cases where TWS just broke compatiblity with their previous APIs
and things just stopped working without any warning.

Again: never update TWS until we say that new version is OK.

UPDATE July 5th, 2006:

Apparently there is no problem at all with TWS 860.9 but there is a problem with *SOME* IB accounts,
that behave strangly. A couple of users reported it and I have seen strange things happening on my own account (”invalid symbol” problem) but … it all fixed itself (or rather IB has changed something to fix that) and all TWS versions (including 860.9) work OK now. No changes in software but things stop and re-start to work. The only reason that comes to my mind is that IB is doing some changes on their servers and this is causing problems on *some* accounts.

UPDATE July 6th, 2006: THE PROBLEM IS NOW FIXED WITH UPDATED VERSION 1.6.6 OF IB PLUGIN

One Response to “TWS 860.9 breaks compatiblity? Or… rather internal IB problem???”

  1. July 5th, 2006 | 5:15 pm

    Apparently the change is that IB does not allow Primary Exchange to be set to “SMART” for Nasdaq stocks and it forces to use SUPERSOES instead. So instead of QQQQ you would need to use QQQQ-SUPERSOES-STK. Instead of GOOG you need GOOG-SUPERSOES-STK, etc. The most surprising thing is that this change has been applied to some accounts only, as it seems :-( :-( :-(